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Sound Byte Lite is a computerized cart machine program. It is very similar 
to the so-called cart machines used at radio stations in the past. Each clip 
(recording) - a jingle, advertisement, etc, was on a cartidge, which could be 
quickly selected and played. Following this introduction are chapters that 
explain how to use Sound Byte Lite.

Sound Byte Lite brings the cart machine to the computer age. You can 
assign select up to 75 recordings to a rack, and assign each to a button. 
Clicking on a button plays that recording. Multiple recordings can be played at 
the same time. 

Sound Byte Lite handles all of the audio formats supported by QuickTime, 
including:
AIFF
WAV
AU
MP3
AAC/m4a

Sound Byte Lite is the perfect application to use whenever you need to 
quickly and easily play a variety of recorded sounds.

Possible Uses:
Radio Stations - jingles, advertisements, PSAs, songs, announcements, and 
more.

Plays and radio/TV productions - perfect for playing sound effects.

DJs - set up your play-list for the evening.

Sporting events - play sound effects when the home team scores, etc.



Rack Window:

When you start the program, you'll see a window with 75 buttons, arranged in 
a 5 by 15 array. The buttons will be empty, until you add a sound file.

Each button represents one sound file (clip) that may be played.  This window 
is also called a “rack” - a term from back in older days of radio when 
recordings (songs, stations jingles, advertisements, etc) were all stored on 
cartridges, or carts for short. The carts were all kept on a rack. To play a 
song or ad, the DJ would grab the cart, plug it in, and play it. Many consoles 
allowed several carts to be queued up ahead of time, so the next one would 
always be ready to play. 

The top line of each button shows the title of the recording. By default it is 
the name of the file, but you can change it. Below this the length of the 
recording is shown, in Hours:Minutes:Seconds. At the bottom of the button is 
a volume control, so you can set the playback level for that particular 
recording. In the upper right corner of the button is an indicator that is 
normally black, and turns green when the recording is playing. Inside this, the 
hotkey character for the recording is shown. Each button can be assigned a 
hotkey, typing this key starts (or stops) the recording. You can also start a 
recording by clicking on the button. Click on the indicator, or the upper part 
of the button. Don’t click on the volume slider area. You can stop playback by 
clicking on the green indicator, or typing the hotkey again.

You can also navigate the carts by using the arrow keys. The up, down, left, 
and right keys will advance from the currently playing cart to the adjacent 
cart, and start it playing. You can also use the space bar to play the next (to 
the right) cart. This is handy if you need to play a sequence of carts in a row 
in order. Just set the up in the rack in the correct order, and hit the 
spacebar to start the next one. If you’re already in the right most column, 
hitting the space bar again will jump to the cart in the left most column of 
the next row.

If the buttons are too small, you can use the Change Cart Size item in the 



Action menu to display larger sized carts. 

Here’s what a button looks like when the recording is playing:

The second line now shows the elapsed playback time as well.

Clicking on the Mute button (or selecting Mute from the Edit menu, cmd-T) 
will mute any currently playing carts, which is handy during a voice-over, etc.

Also be sure to check the section on Preferences, which can set some useful 
features of Sound Byte Lite.

There are two ways to assign a clip to a button. The first, and easiest way is 
to just drag the sound file into the button.  

Holding down the shift key when you drop the file will change the file that is 
played, but keep the button color, text, hotkey, etc all the same. 

To change the details of a cart button, right click on it, or, you can click on 
the button while holding down the command key (the alt key under Windows). 
This will bring up the a window called "Cart Options", shown below:



The name of the file is automatically used as the button title. If you'd like to 
change the title, type the name you'd like to assign to this sound clip in the 
field called Title. You'll want do do this after you select the sound file, or the 
name you've typed in will get replaced by the name of the sound file, and 
you'll have to enter it in again.

If you select the Abort other sounds playing option, then whenever you 



play this sound, any other sounds that are currently playing will automatically 
be stopped. This can be much more convenient than having to manually stop 
the other sounds that may be playing.

When Click restarts playback is checked, a cart will restart playback 
from the beginning when clicked, rather than stop playback.

If you select the Loop option, then when the sound is done playing, it will 
automatically be re-played.

If you select the Disable After Playing option, then when the sound is 
done playing, the cart will automatically be disabled. It will appear faded in the 
Rack, and you won’t be able to play it again until you’ve selected the Reset 
Disabled Carts option in the Edit menu. This is useful when you only want to 
play a sound once, and don’t want to accidently play it again, and want to 
make it so that unplayed sounds are more obvious in the Rack window.

The Play Backwards option will cause playback to start at the end of the 
recording, and it will be played backwards. Note that there may be some 
clicking or other distortions to the sound when this option is used, nothing 
can be done about that. Please be sure to fully test this option before using 
it in a production setting, if it is important to you. 

The Click Start Aborts Others option, when enabled, will stop playback of 
any other carts which are playing, when this cart is clicked to start playback. 
This works the same as the option in the Sound Byte Lite preferences, but 
allows a cart-by-cart control of this feature.

The Click Pauses Playback option, when enabled, will pause playback of 
this cart when the cart button is clicked, rather than stopping playback 
which is the default operation. This works the same as the option in the 
Sound Byte Lite preferences, but allows a cart-by-cart control of this 
feature.

If you select the Lock Volume option, then the volume slider can’t be 
adjusted. This is to prevent accidently changing the volumne setting when 
you click on a cart to play it.

You can also assign a hot key to this sound. This allows you to play the clip 
by just typing that key, without using the mouse. Hot key's may include the 



shift key, that is, you can use both upper and lower case letters.  If you’d 
like to use one of the function keys (F1, F2, etc) type in the function key 
name (which must be in upper case). Note that some function keys have 
special uses with various operating systems, and may not be used. 

Clicking on the "Set Button Color..." button lets you change the color of the 
button. This can be very handy if you want to color code buttons to make 
them easier to find. You'll get a color picker window, with lots of options, 
depending on which operating system you're running. Select the color, then 
click on OK.

If you want to change several carts to the same color, the easiest way is to 
change one of them, then select Copy Cart Color under the Maintenance 
menu. An open hand cursor will appear. Click on the cart with the color you 
wish to apply to other carts. The cursor will change to a closed hand. Then 
click on the other carts you wish to change to that color. When you’re done, 
hit the ESC key, and the cursor will change back to the normal pointer. 

Set In/Out brings up another window, to allow you to precisely set the in 
and out times. Read further down under Set In Out Window for more details.

The Fade Rate field specifies how quickly the sound fades to silence when 
you select the Fade Current Cart item from the Edit menu. Larger numbers 
cause faster fades, and the fading rate is linear. A value of 1, for example, 
fades from maximum volume to complete silence in about 32 seconds. A 
value of 8 does the same fade in about 4 seconds. 

Fadeout specifies when (referenced from the end of the track), the cart 
should automatically start to fade out. For example, 5 means that 5 seconds 
before the end of the track, it will begin to fade (at the specified Fade Rate). 

You can check Fade out cart on click to have the cart fade out if it is 
clicked while it is playing.

Checking Fade In will cause the cart to fade in when it is played.

You can use the Rate value to change the playback speed. A value of 1 will 
play back at the normal speed. A value of 1.1 would be 10% faster than 
normal, 2 would be double speed, etc. Negative values can be used for 



reverse playback, although the sound may be distorted.

The Pitch value, as expected, controls the pitch of the audio. Here, zero is 
normal pitch, a value of 1.0 would be an increase of one cent, 100.0 is one 
semi-tone up, and 1200.0 would be one octave higher. Negative values can be 
used to lower the pitch.

The Repeat value allows a cart to be automatically replayed. Enter in a time 
(in HH:MM:SS) as the repetition period. When you click on the cart, it will play 
normally. Then, after the repetition period, it will be played again, and so on. 
This can be used to play periodic announcement messages, etc. When this is 
active, the indicator box in the upper right corner will be blue, rather than 
the suual black. To stop the periodic playback, click on the cart again, and 
the indicator will turn back to black from blue.

The MIDI value allows you to specify which note on a connected MIDI keyboard 
will cause the sound file to play (it works just like a hotkey). You need to have 
MIDI enabled in the Sound Byte Lite Preferences for this to work. Just hit the 
note on the keyboard and the value will appear in the entry box, or type in 
the note value.

Using the popup menu at the bottom of the window, you can select the sound 
output device to use, if you want the sound to play on a device other than 
the default. You can also specify the channel numbers to use (if your device 
has more than two output channels) for the left and right outputs. These 
settings will override any in the overall Sound Byte Lite preferences.

When you're done, click on the OK button.  Clicking on the Clear button will 
erase the button name and file association, essentially erasing the button 
entry.



Set Cart In Out Window

This window allows the cut in and out times for the cart to be precisely set. 
At the top of the window, the waveform for the sound file is displayed. The 
slider below and to the right allows the magnification level to be changed, 
letting you zoom in and out. You can also scroll around a zoomed in waveform 
use the scroll bar below it. 

Shift clicking sets the in point, and control clicking sets the out point.  The 
out point is referenced in two ways, first the time from the start of the file, 
and second from the end of the file. You can change either, and the other will 
also change appropriately. 

The portion of the sound file that will actually be played is surrounded by 
gray. 



The fade rate and fadeout time from the end of the file, as well as whether 
or not the sound file will fade in, can also be set.

The Play, Pause, and Stop buttons work as expect.



Drag and Drop

If you want to move buttons around (within the same rack), you can just drag 
one button on top of the other. They will automatically trade places. If you 
want to replicate a button, hold down the shift key as you drag it to a blank 
cart, and you will get a copy. If the destination cart is not blank, it will be 
overwritten. You need to grab the lower right corner of the cart to be able to 
drag it.

Playing a Sound

To play a clip, just click on the button, or type the hot key. The indicator in 
the upper right of the button will turn green, to show that the clip is playing. 

The volume slider can be used to adjust the playback volume of the cart. You 
can also position the mouse cursor over the cart, and use the scroll wheel.

Clicking on the indicator while the clip is still playing will stop playback. You 
can have more than one clip play at the same time.

You can stop all currently playing clips by pressing the ESC (escape) key.

Holding down the control key while clicking on a button will bring up a window 
that will let you specify the starting point in the recording to begin playback. 
This is useful if you do not want to start playback at the beginning. After 
entering in the start time and clicking OK, the cart will be paused. Select 
Pause Playing Carts from the Edit menu (control or command U as the 
shortcut) to begin playback.

More About The Rack

Under the Rack menu is your rack.  The name of the rack can be changed by 
selecting “Rename...” from the Rack menu while that rack is the currently 
active window.

Your rack is automatically saved when you quit the program, or close it.

If instead of the volume slider, you’d rather see a progress bar showing the 



amount of the cart that has played so far, select Show Play Progress from 
the Edit menu. Each cart will now look like the following:

With this view enabled, you can click on the progress bar to set the playback 
position of the cart. You do this while it is playing, or before it plays, to cue 
the position, then click on the cart to start playback.

Clicking on the cart while holding down the shift and control keys will bring up 
a window to allow you to precisely cue the playback start time, down to the 
second.

You can select Show Volume Sliders to get the sliders back, or select Show 
Nothing if you’d rather see neither.

Selecting Max All Volumes from the Edit menu will set all volume sliders to 
the maximum volume.

Selecting Fade Current Cart from the Edit menu will fade the volume of the 
currently playing cart over a few seconds. This operation of this function is 
undefined if you have more than one cart playing. You can select the fade 
rate for each cart by cmd-clicking on the cart to bring up the editing window 
for that cart.

Selecting Pause Playing Carts from the Edit menu will paue the playback of all 
active carts. Selecting it again will start them playing from were they left 
off.

If you want to add several files to a rack at once, select all them, and drop 
them onto the small area labled “Drop Files Here”. Each file will be assigned 
to an empty cart button.  You can always re-arrange the order of the carts 
by dragging them around, if they don’t land in the order you wish.

Clicking the MUTE button will mute playback of carts. Clicking with TALK 
button will change the volume to a lower setting, you can adjust this setting 
while TALK is pressed, and it will be saved for the next time you press TALK. 
This can be useful when doing a voice-over.



Queuing Carts

You can queue carts on a rack, so that as soon as one cart is done playing, 
the next queued cart will play. This lets you quickly and easily specify a 
sequence of carts to play, without having to manually start each cart at 
exactly when the previous cart ends.

To do this, you must enabled queuing in the Sound Byte preferences if you 
would like to be able to queue all carts, or you must enable it on a cart by 
cart basis. When a cart (or all carts) are enabled for queuing, you lose the 
ability to play two or more of those carts at the same time.

When a cart is playing, if you click on another cart (or type the hotkey for 
it), that second cart will not start playing immediately, but will instead be 
queued. When the first cart is done playing, it will then start playback.

Carts that are queued will have a number displayed on the cart, in a large 
blue font, indicating the position in the queue. Number 1 means that cart will 
start playing immediately after the currently playing cart stops, queued cart 
2 will play next, and so on. As the carts move up in the queue, the displayed 
numbers will update.

If you have two or more carts with the same hotkey, and type the hotkey to 
queue them, both will be queued, but they will not play at the same time. The 
first cart (as defined by highest row and leftmost column) will play first, 
then the next cart.



Play List

The Play List allows you to select cuts to play ahead of time, organize them 
in a list, and control their playback.

For each recording in the playlist, the title (name of recording file), length in 
Hours : Minutes : Seconds is shown, as well as how much time into the 
playback session that recording will start. A small black dot appears to the 
right of the title of the active (currently playing or next to play) recording.

To create a play list, select New PlayList... from the File menu. You’ll be 
asked to name the play list. You can bring up a list of all of the playlists by 
selecting Show Play Lists Window from the File menu. Just double click on a 
playlist in that window to open it.

You can drag a cart over to the play list window from a button on the main 
window, or you can drag a sound file over directly from Finder.  Drop it onto 
the “Drag Files Here” box to have them appended onto the end of the play 
list, or drag them into the position where you want them. You can always 
change the order of items in the play list up or down, by dragging the entries 



around.

You can then drag additional cuts over. Dragging them after cuts already in 
the play list schedules them later. Dragging them onto an existing scheduled 
cut schedules them before that cut.

You can delete a scheduled cut by selecting it, and selecting Delete Playlist 
Track from the Edit menu. You can can also re-arrange the order by 
dragging entries around.

The play list has seven buttons. Let’s go through them in order from left to 
right:

 Play - Clicking this button starts playback of the selected recordings, in 
order. A small dot is displayed next to the active (playing) cut.

 Stop - Clicking this button stops playback. Clicking Play again will start 
the active recording, at the beginning.

 Pause - Clicking this button pauses playback. Clicking Play will start it 
again, right where it left off, not at the beginning of the recording.

 Skip - Clicking this button will stop playback of the currently playing 
recording, and start playback of the next. Think of it as a way to abort a 
cut, and jump right to the next one.

 Rewind - Stops playback, and selects the first recording as the active 
recording. When play is clicked, the first recording will start playback.



 Loop - When depressed, the loop button will cause the playlist to start 
over again, after the last cut is finished.

 Play One Cut - Click once to select, again to de-select. When selected, 
only one recording will be played when Play is clicked. Pressing Play again will 
play the next recording. Useful to queue up several recordings in a row, and 
play them one by one, under your control as to when they start.  For 
example, sound effects for a play or other production, etc.

Hitting either the spacebar or return/enter key when a playlist window is 
active will begin playback of the currently selected track.

The up and down arrow  keys can be used to navigate up and down through 
the list of tracks.

The left arrow key will restart (or start) playback of a track.

The right arrow key will stop playback of the current track and start 
playback of the next track.

Add Pause - Clicking this button adds an entry called PAUSE PLAYBACK. You 
can drag this entry to position it wherever you wish, and you have have 
several of these in a playlist. When playback reaches this entry, it will stop. 
You can then click the play button to start playback again with the next 
entry. This allows you to create a playlist for an extended time period, where 
you will only want to play a few tracks in a row, wuch as a series of 
commercials or other announcements, songs, etc. 

Add Delay - Clicking this button adds an entry called DELAY PLAYBACK. You 
can drag this entry to position it wherever you wish, and you have have 
several of these in a playlist. When playback reaches this entry, it will stop, 
then resume after a specified time period. This period defaults to 10 
seconds, and may be changed by double clicking the DELAY PLAYBACK entry.

The Cross Fade entry can be used to specify a time period, in seconds, over 
which the currently playing track will be faded out, while the next track will 
be faded in.



Each  track also has a Cut In and Cut Out time, in seconds, that you can 
specify. The track will start playing at the Cut In time, and the end of the 
track will be ofset by the Cut Out time (for example, if a track is 3 minutes, 
20 seconds long, and the Cut Out time is 5 seconds, then it will stop playing 
at 3 minutes, 15 seconds).

To change the Cut In or Cut Out times, or to delete a track, double click on it 
to bring up an editing window.

There is a volume control for each playlist, which controls the playback 
volume of tracks on that list.

Your play list is automatically saved when you quit the program, or close it.

You can open a window with a list of all of the playlists that are in your 
Playlists folder by selecting Show Play Lists Window from the File menu. 
Double clicking on an entry will automatically open that playlist. Note that you 
need to save your playlists in the Playlists folder for them to appear in the 
listing.

You can drag and drop a playlist file onto a cart button in a rack. When you 
do this, the name of the playlist will appear as the cart’s title. If you click on 
the cart, the playlist will open, and the first track in the playlist will play. 
Each subsequent click on the cart will play the next track of the play list.

A playlist can be made to open and play when a cart button is pressed. Drag 
and drop the file for the playlist (from the Finder or Windows Explorer, not 
the list of playlists within Sound Byte Lite itself) to a cart. The name of the 
cart will become the name of the playlist. 

When this cart is run, the playlist will automatically open, and playback will 
begin. If the playlist is set to only play one track at a time, then only the 
first track will play, each subsequent click of the cart (or press of the 
hotkey) will play the next track.

The popup menu can be used to specify the sound output device, and the left 
and right channels can also be specified (or leave them black to use the 
defaults).



Timed Play List

The Timed Play List allows you to create a set of sound files, each one will 
play at a user defined time of the day. This can be a handy way to have lead 
in or out jingles play at certain times, without manual intervention. Very 
useful for a live show, for example. You could have a certain clip 
automatically start to play at certain times, to remind you that it’s time to 
go into a break.

Create a new timed play list window, and then drag sound files (or carts) into 
it.  The start time for each recording will default to 00:00:00 which is 
midnight. Go to this value, and click it twice to allow you to edit it. You can 
then change it to whatever time of the day you wish. Use 24 hour time, that 
is, 2 PM would be 14:00:00.  When you close the window for the first time, or 
if you have made changes to it, you’ll be asked to give it a name so it can be 
saved. 

When the specified time of any recording in an opened timed play list window 
is reached, that recording will start to play. You can have multiple recordings 



play at the same time, if you wish.

You can open a window with a list of all of the timed playlists by selecting 
Show Timed Play Lists Window from the File menu. Double clicking on an entry 
will open that playlist. 

By selecting Reset Start Times from the Management window, the start 
times for each track in a timed playlist window can be changed. You will be 
presented with a small window, where you specify the start time for the 
first track (it will default to the current time). Each subsequent track’s 
start time will also be changed, keeping the same relative spacing between 
start times as previously existed.



P re fe rences

The following preferences can be set:

Space skips to next cart
Hitting the spacebar will cause the next cart (to the right) to start playing.

Space aborts playback
Pressing the spacebar will stop playback, handy if hitting the small ESC key is 
too difficult. 

Arrow Keys Don’t Start Cart Playback
Using the arrow keys (or remote) to move the selector to chose the next 
cart to play won’t actually start playback, you need to press enter to do 
that.

Check for IR Remote
Will check for the presence of an Apple IR Remote (only works on Mac OS X). 
If found, you can use the up/down/left/right buttons to select the cart to 
play next, and the play button to play it. 

Cart start aborts other carts playing
Starting a cart will stop any other playing cart(s)



Play Carts Continuously
After one cart ends, the next cart (to the right) will play. When the end of a 
row is reached, the first cart in the next row wil play. 

Click on playing cart pauses playback instead of stopping it
Instead of stopping, a currently playing cart will pause when the cart button 
is clicked. Playback will resume when it is clicked again.

Fadeout cart rather than stopping it
Instead of abruptly stopping, a currently playing cart will fade out when 
another cart is started.

Turn entire cart green when playing
Checking this will turn the entire cart green, rather than just the small 
activity box, making it easier to see which cart is playing.

Flash cart red when nearing end
Checking this will cause the cart to flash red when it is nearing the end of 
playback.  Enter the number of seconds before the end of playback in the 
box next to the option.

Time Offset
This allows you to take into account time delays.  Enter a value here in 
seconds. The clock on the rack window will run ahead by this amount. Any 
timed play lists will then start ahead of time by this amount as well.

Click restarts playback
When checked, a cart will restart playback from the beginning when clicked, 
rather than stop playback.

Load Sound Files To RAM
When checked, Sound Byte Lite will load each sound file in a rack to the 
computer’s memory. This can reduce the delay before playback, at the 
expense of taking longer to load a rack, and potentially using a lot of 
memory.



Randomly Play Hotkey Carts
Normally, if more than one cart has the same hotkey, typing that hotkey will 
result in all those carts being played. When this option is checked, only one of 
the carts, randomly selected, will play.

Serial Port
If a serial port is selected in the popup menu, Sound Byte Lite will assert the 
RTS and DTR lines when a sound file is being played. This can be used to 
control external hardware, such as a transmitter.

MIDI
When enabled, Sound Byte Lite will allow notes from a MIDI keyboard to 
initiate sound file playback. If no MIDI input device can be found, an error 
message will be displayed when Sound Byte Lite starts. You can also specify 
a MIDI note value that will abort sound playback, much like the ESC key. Just 
hit the note on the keyboard and the value will appear in the entry box, or 
type in the note value.

Be sure to plug in your MIDI device before running Sound Byte Lite. You can 
select which MIDI device to use via Select Midi Device... from the Management 
menu

Sound Output Device
you can select the sound output device to use, if you want the sound to play 
on a device other than the default. You can also specify the channel numbers 
to use (if your device has more than two output channels) for the left and 
right outputs.



Locking Sound Byte Lite Against Unauthorized Changes

It may be desirable to prevent users from making accidental changes to cart 
settings and rack layouts. This can be done by selecting Lock Settings from 
the Edit menu, and checking the checkbox. 

When checked, users will not be able to edit cart options, drag carts, or add 
new carts to the rack.

To re-allow changes to be made, uncheck this checkbox.


